CVE-2024-51567
CyberPanel Incorrect Default Permissions Vulnerability
- Severity
- critical
- CVSS v3
- 10
- EPSS percentile
- 100%
- Known exploited
- yes (CISA KEV)
- Vendor
- CyberPersons
- Product
- CyberPanel
- Published
- 2024-11-07
- Modified
- 2026-08-04
Description
upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.
Informational only. Not a warranty of security, completeness or fitness for any purpose. Derived from NVD, CISA KEV, FIRST.org EPSS and vendor advisories (CVE Program List v5); those sources change continuously and may be incomplete or incorrect. Verify every remediation against the vendor advisory before acting. Absence of a finding is not evidence that no vulnerability exists. Not endorsed by NVD, CISA, FIRST or any vendor named.
Raw record
{
"id": "CVE-2024-51567",
"title": "CyberPanel Incorrect Default Permissions Vulnerability",
"description": "upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.",
"severity": "critical",
"cvss": 10,
"epss": 100,
"kev": 1,
"vendor": "CyberPersons",
"product": "CyberPanel",
"published": "2024-11-07",
"modified": "2026-08-04T05:16:31.190",
"source": "nvd",
"remediation": [],
"disclaimer": "Informational only. Not a warranty of security, completeness or fitness for any purpose. Derived from NVD, CISA KEV, FIRST.org EPSS and vendor advisories (CVE Program List v5); those sources change continuously and may be incomplete or incorrect. Verify every remediation against the vendor advisory before acting. Absence of a finding is not evidence that no vulnerability exists. Not endorsed by NVD, CISA, FIRST or any vendor named."
}